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Overview of Caption Pro Capabilities 
 

1. Add, remove or replace a caption bar containing a caption and a sub-caption in JPEG, HEIC, 
TIFF or PNG images. Caption text may use any installed font in any Windows language. Any 
background colour may be used for the caption bar. The caption may contain one or both of 
the following: 

a. Caption  comprising continuous text 
b. Sub-Caption may contain 

a. -Multi-line text  
b. -Part of an image selected separately 

       Captioned images are output in JPEG format. 
2. Support caption editing by retrieving applied captions, aspect ratios, and caption sizes after 

application   
3. Adjust image aspect ratios 
4. Load multiple files or the file content of multiple folders and customise the sequence in which 

they appear 
5. Process or display images individually or in groups  
6. Obtain image caption text automatically from metadata created by Photo Gallery, Picasa, 

Google Photos, Windows Photos and other applications, including GPS location data 
7. Detect and label faces appearing in images and create captions from face labels 
8. Search and display images containing specified text in the captions 
9. Store processed images as new files with the same extension or replacements for existing 

ones, optionally with resampling 
10. Store image caption text in IPTC/XMP metadata, while preserving all existing metadata or only 

EXIF metadata 
11. Store captioned JPEG images with default (75%) or high (94%) quality. 
12. Set image file Modified date to date on which photo was taken or to arbitrary date 
13. Change image file names to reflect ordering by Modified date 
14. Display caption and sub-caption text together with video data for .mov, .mp4 and .3gp format 

video files 
15. Embed caption in video files in .mov and .mp4 formats 
16. Edit caption and sub-caption text which has been shown with videos in any of the above 

formats and edit embedded caption data. 
17. Display loaded images and videos as a slideshow, with uncaptioned items optionally excluded 

and optionally pause slideshow when successive images have significant difference. 
 
Caption Pro requires Windows 10 or newer (64-bit operating system) with .Net 4.7.2 Framework 
or later. The Desktop application is 64-bit. Caption Pro operates with JPEG, HEIC, TIFF and PNG 
format image files and video files with .mov, .mp4 and .3gp extensions, but .3gp files do not 
support caption embedding. 
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 Installation, Running, and Uninstallation  
The self-extracting installer Caption ProX.XX.XXX.exe (where X.XX.XXX is the version identifier) 
should be downloaded from the Aleka Consulting website 
https://captionpro.com.au:444/AlekaConsulting/index.php/caption-pro-download-form/. The 
application will run on Windows 7 or later, but the Speech Input facility will not work on 
Windows 7 systems. Image captioning using HEIC format image files as captions will only work 
on Windows 11 or later.  Double-click on the downloaded file to install the program. If an 
installation location within the user’s profile is chosen, the option to send files to Caption Pro 
via a  right-click on single or multiple files will be created once the program has been run once. 
The option appears in the Send To menu as shown below: 
 

 
Figure 1 Context menu to send files of folders to Caption Pro by right-clicking on file or files  

 
As Caption Pro can only process JPEG, TIFF or PNG  files, any other files selected will be skipped. 
The program can be found in the Aleka Consulting->Caption Pro folder in “All Programs” as 
shown below: 

 
If desired the program can be pinned to the Start menu by right-clicking on the program and 
selecting Pin to Start Menu. 
 
Caption Pro may be uninstalled from the Control Panel->Programs and Features list in the same 
way as any other application. 
 
Installing Caption Pro on a machine from a user account with Administrator privileges will make 
the program accessible to all users of the machine. However, non-Administrator users will need 
to access a copy of the template database FindAlike_Load.vdb5 when running Caption Pro for 
the first time. This database can be downloaded from the Caption Pro web site and should be 
placed in the C:\Users\Public\Documents folder. 

First Run 
After installation, a Demo Desktop license is automatically created when Caption Pro is run 
(either by clicking the Program entry or by sending selected files to Caption Pro via right-click 
context menu), which expires 30 days after installation or after 25 captions have been applied 
or removed. A Demo license can only be used once. If Caption Pro is uninstalled and re-installed 
by the same user, a license must be obtained from Aleka Consulting.  

https://captionpro.com.au:444/AlekaConsulting/index.php/caption-pro-download-form/
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Licensing 
Purchased Caption Pro licenses are permanent but version-limited after expiry, meaning that 
newer versions cannot be run after license expiry, which is 12 months after purchase. The 
availability of new versions can be checked via the Help-> Check For Update menu item. The 
version limit is applied to the first two parts of the version string shown in the Help->About 
menu, and is shown in the License screen below to the right of the Buy License button. Demo 
licenses do not show the version number and operation is not possible after a Demo license 
expires. 
 
License key installation is done by clicking on the License top-level menu to show the following 
screen:  

 
Figure 2 Licensing screen 

The screen shows License OK at the bottom left of the screen if the license is valid. If it is not, 
the reason is shown. The screen also provides a link to purchase a license from the Aleka 
Consulting webs site via Paypal by clicking the Buy License button. A license may be used on up 
to 2 computers. 
 
For a Desktop Demo license, the number of captions or tags applied is shown, and the maximum 
number allowed with a Desktop Demo license (25).  
 
Any Application or Top-Up license code received is entered in the License Key text box and the 
Apply button clicked. License details are then shown and the Max Premium Transactions count 
is increased if a Top-Up license key is entered. Premium Transactions license Premium Face 
Recognition and Megadetector analyses. Note that Top-Up licenses can only be entered once, 
and cannot be entered for Demo licenses. The option to restart Caption Pro after the license has 
been accepted should be selected.   
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Integration with Other Applications 
 
Caption Pro may be integrated with other applications. Details are given in the document 
Integrating Caption Pro. 

Operating Caption Pro 
If a license is valid, a Caption Pro Usage screen appears showing summarising the possible 
modes of operation. 

 
Figure 3 Caption Pro Usage Screen 

Checking “Don’t show this screen again” prevents the screen from being shown on startup.  The 
screen can be shown via the Help->Hints menu option. 

Simple Interface 
Closing the Hints screen via the x button in the top-right corner or the Close button reveals the 
main screen with Simple interface enabled by default  as below: 

 
 
Figure 4 Main screen with simple interface and no file loaded 

This screen allows loading of a single file by clicking the Open File button  . A single, 
continuous caption as entered in the Caption box can then added in a caption bar below the 
image whose height is the percentage by the Height combo box by clicking the Apply button. 
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Clicking the License button  shows the Licensing screen as shown in Figure 2 and clicking the 
Close button  closes the application. 

Advanced Interface 
The Advanced interface option can be shown by clicking the Advanced button in the Interface 
box as shown below: 

 
Figure 5 Main screen with Advanced Interface 

Menu options and other controls are now shown and multiple file can now be loaded. This 
screen allows setting of continuous captions and multi-line sub-captions using the Caption and 
multi-Line Sub-Caption text boxes below the image. The proportion of the original image or 
video height used for these is set from the drop-down boxes at the right of the text boxes.  The 
Alignment radio buttons determine whether the lines in the Sub-caption are centred or left 
aligned. The down arrow button on the lower rights hides all controls below the caption box. 
The double-headed arrow allows the height of the Caption Pro window to be changed by 
clicking and dragging. This feature is useful when using Caption Pro from a tablet or mobile, with 
touch controls rather than a mouse. The application window can be resized to allow a view of 
the touch keyboard below it.  
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The button to the left of the down arrow button toggles between large and normal size for all 
controls as shown below. The button icon toggles between a plus (indicating that clicking will 
change to the Large mode) and a minus, indicating that clicking will return controls to normal 
size. This view is useful when accessing Caption Pro on a remote server from a mobile device 
with a small screen. 

 
Figure 6 Main Screen in Large View 

 
The license status and the number of days to expiry are shown at the bottom of the main 
screen. Selection of files or folders is disabled without a valid license.  The Metadata menu item 
is only enabled once data has been loaded. 

Extracting Multiple Photos from Images  and Colourising them with 
ImageSplit 
Photos can be extracted as individual files from  images of multiple photos from a scanner or a 
camera via the Files->ImageSplit.. option. Colourisation can also be applied to split images or 
images as loaded. Extracted photos can then be processed as described in this manual. Help for 
this process is available from here. 

        Loading And Displaying  Files and Folders 

Files 
Single or multiple image files or videos in supported formats can be loaded via the File-> File(s).. 
option which shows a file browser searching for supported file extensions 

 
Figure 7 Selecting files with image or video extensions 

Files which are less than 200 pixels in height will not be displayed, as they cannot be captioned 
legibly.  Non-supported format files will not be visible for selection. The largest file (by pixel 

http://captionpro.com.au/ImageSplit%20User%20Manual.pdf
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dimensions rather than storage size) which can be captioned depends on available memory, but 
160-megapixel files have been successfully captioned. Larger files may require resampling. 
 
Processing of HEIC format image files will be much slower than other image formats. Windows 
11 does not display thumbnails of image files in this format. After text or image captions have 
been applied, files are saved in JPEG format with extension .jpg. 
 
If multiple files are selected, they are displayed in the default display order (Modified date) 
using the row of movement buttons below the image on the LHS, whose function are shown 
below: 

 
The display order can be changed in the Options screen and via the Edit->Reorder/Append 
menu option. A scroll bar is shown below the image when multiple files are loaded, allowing 
movement through the collection of loaded files. Movement of the scroll bar does not result in 
application of captions. Files which do not have supported extensions are not loaded.  

 
Figure 8 Screen after loading multiple images, showing slide scroll bar 

 The image is shown in the center of the screen, and its size may be increased by dragging the 
window boundary or by selecting the square Full-Screen option in the control box in the top RH 
corner.  
 
Video files are displayed with display controls beneath the image as shown below if Show Video 
Controls is selected from the Options screen. If the video controls are hidden, the same 
functionality can be accessed by right-clicking the video image. 
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Figure 9 Uncaptioned video file display (left),  and controls accessed via right-clicking in the video (right). 

 
If a caption and/or a sub-caption is applied to a video, the display is as shown below.  

 
Figure 10 Video display with embedded caption  

The alignment and aspect ratio controls are disabled for video files. Sub-captions are always 
displayed in the centre. The four movement buttons  show the first, next, previous 
and last images/videos of those selected. If either the caption or the sub-caption has been 
changed, the caption and sub-caption are added to the image, or written to file metadata. The 
keypad left and right buttons on the keyboard perform the same function as clicking the 
previous and next buttons on the screen. 

 
The Zoom control allows images to be zoomed so that the display area exceeds the window size. 
Zoomed displays can be panned by clicking and dragging in the image. 
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Figure 11 Zoomed Display 

Video File Limitations 
There are some limitations on the processing of video files, which may have only .mov, .mp4 or 
.3gp extensions. Only caption text (not sub-caption text) can be embedded in the video as a 
single line. The embedded text is shown in black on a white background or vice versa and the 
font style cannot be changed. Embedding is slow, taking much more than the running time of 
the video to execute. Captions cannot be embedded in .3gp files. 
 
Video files may be skipped if they are included in a selection of files to which batch processing is 
being applied. Editing, aspect ratio setting, use of image captions and logos, the selection of left 
or centre alignment for sub-captions, caption font and background colour are not available for 
video files.  

Folders 
Image and video files in single folders can be loaded by selecting a folder from the File-> File(s) 
in Folder.. menu option. This shows a folder browser. Selecting a folder will show the following 
screen, allowing all files in the selected folder and its sub-folders, or only files from the selected 
folder to be loaded: 
 

 
Figure 12 Recursive/Top Only option screen when loading a folder. 

When multiple files are loaded, the movement buttons may be used to view different files. Files 
are ordered by Modified date by default. 

Loading from Google Photos 
Images in Google Photos albums can be captioned by downloading the album via More 
Options.. ->Download All when viewing the album in a browser. The download will appear as a 
Zip file, which should be unpacked and the parent folder of the files selected. Files may have a 
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variety of extensions, including .jpg, .heic, .mov and .mp4. No descriptions added by the album 
owner or comments from other users are available. If descriptions are to be used as captions, 
the procedure described in  
 
Using Caption Data from Google Photos should be followed. This can only be done by the album 
owner. Captioned images from Google Photos can be uploaded as a new album from within 
Google Photos by selecting all files within the folder containing the captioned images.  This 
process is slow. 
 

Drag/Drop, Paste, Append and Re-order 
Files and folder content can also be loaded by dragging and dropping, or by pasting images or 
files copied from the Clipboard. These options are accessed via the File->Paste/Drop option, 
which shows the following screen: 

 
Figure 13 Drag/Drop and Paste Screen 

Drop and Paste operations can be performed repeatedly, allowing the creation of a sorted set of 
images from multiple sources. This facility is particularly useful in preparing a display of photos 
from multiple sources, such as a mobile phone paired with a computer and an SD card from a 
digital camera. 
 
Files can be sorted by any of the four options shown in the Order By buttons. If Date Taken does 
not exist, the file Modified date is used instead. Clicking Close displays the loaded images in the 
selected order, and Cancel closes the screen without displaying any of the added items. If a 
folder is included in the dropped items, a screen will be shown asking whether files in sub-
folders should be included. Items from multiple drops can be added. 
 
Images and files pasted onto the clipboard can be loaded by clicking Paste. When images are 
pasted,  file is created in a temporary folder with the current modified date with the name 
Paste(nnn).jpg, where nnn is an incrementing counter 
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After one or more items have been added the Edit checkbox is enabled. Checking it displays 
thumbnails of the loaded items as shown below (after enlarging the screen by dragging a 
corner): 

 
Figure 14 Drop/Screen showing re-ordering screen 

The original sequence number and file name are shown below each image thumbnail. Single or 
multiple items can be dragged to a new location to re-order. If the number of images exceeds 
the available screen space, images can be dragged to new locations above or below the display 
area. The display will scroll to show additional images in the same way as File Explorer. 
Releasing the dragged image at a newly displayed image will replace that image with the 
dragged item. Scrolling can be terminated by clicking on the region just outside the image 
display. The display of images can be terminated by clicking the Stop Loading button. 
Selected items can be deleted from the selection by clicking the Delete Selected button. 
  
 Clicking Close will display the items in the order shown in the screen. This order will not persist 
between runs items have been re-ordered. 
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Showing or Hiding Controls 
When captioning large numbers of files, it may be helpful to hide all controls below the caption 
box. This can be done by clicking the Hide Controls (Down arrow) button on the lower RHS of 
the screen: 

  
Figure 15 Screen with all controls shown 

 
Figure 16 Screen with only Caption control visible (some controls are hidden)  
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In hidden controls mode, captions may be entered simply by typing the required caption, 
moving to another image with the left or right keypad buttons. Movement to another image 
after changing the caption results in its application.   This allows rapid entry of simple captions. 

Saving Images as PDF 
To save all images as a single PDF file, select File->Save as PDF. If images have had captions 
applied, the captioned images are saved. Uncaptioned images will be saved as loaded.  Images 
may have their dimensions reduced by a factor 2 or 4 to reduce the size of the PDF file. Saving 
to PDF may be useful for groups of images such as pages of a document.  Image ordering within 
the PDF file may be changed as desired. 

Changing Image Display Height 
The height of the image or video display can be changed by dragging the double arrow button, 
or by dragging the boundary between the upper and lower parts of the screen where the icon 
changes to a double headed arrow, as shown below: 

 
Figure 17 Changing Image Display Height 
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Batch Button – Captioning or Changing Multiple Image  Files 
 

The Batch button 
 
 applies automatic captioning to loaded images or a subset of them 

(optionally skipping videos, as embedded captioning of these is very slow). Settings defined in 
the Options screen are used  if any source options other than None are checked in the Options 
screen. The button is disabled if the Image rather than the text Option is selected for the Multi-
Line sub-caption. If Location is selected as a captioning source and there is no GPS data in the 
file, no location text is added to fields specifying it as a source. The checkbox to the left of the 
Auto-caption button indicates whether GPS data is present in the file. Clicking the Batch button 
shows the following screen: 

 
Figure 18 Batch Process Options 

The Apply Seq button processes files from the current image up to the sequence number shown 
to the right of the button. The image sequence number n is shown in the main form title bar as  
n of x where x is the sequence number of file loaded. This allows processing of a subset of 
images. 
 
The five options (from top to bottom) are to: 

• Define the caption for each image from metadata. The metadata may be the folder 
name, file name, IPTC Object Name (Title), IPTC Caption/Abstract(Description) or the 
address where the image was taken, as derived from GPS data. The selected metadata 
sources may be changed by clicking the Change.. button, which shows the screen as 
shown in Figure 56 on page 50. 

• Set the caption and sub-caption to values entered on the current screen. Clearing the 
content of the caption and sub-caption boxes (and the tag box if shown) will delete all 
added data. 

• Reset the aspect ratio to the value set on the main screen 

• Change font and background colours to those set in Options screen 

• Re-apply stored captions to the images. 
 
All batch processing uses the caption font specified on the Options screen shown on in Figure 56 
on page 50. If no caption has been applied, the font and background colours are as specified in 
the Options screen. 

 
The checkbox Add Sequence No. to Name changes the name for the processed file by adding 
the sequence number before it padded with leading zeros. As the sequence is always by 
ascending Modified date, this ensures that sorting by name (which is how albums of files are 
displayed on tablets and other devices) gives the same ordering as Modified date.  



Caption Pro User Manual 

 20 Aleka Consulting 
  www.alekaconsulting.com.au 

 
The checkbox Set Modified Date to Date Taken allows setting of Modified Date to the same date 
as stored in the EXIF Date/Time field and can be used if the file Modified date differs from the 
date on which a photo was taken. If the file does not contain this EXIF field (for example, if was 
produced by a scanner), the Modified date is unchanged. Note that individual image Modified 
dates can be set via the Set Modified date button on the main screen. 
 
The Close button closes the screen without initiating any operation. 
 
 

Slideshows 
Slideshows can be used for displaying multiple images and videos sequentially without user 
intervention and with caption input controls hidden. Slideshow options are only enabled if 
multiple items are loaded via the File->Files in Folder or by selecting multiple files with File-
>File(s). While a slideshow is playing, the Step Forward, Step Back, Copy To Folder, Interval Copy 
To Folder, Move Play Start To and Skip Uncaptioned options are disabled 
 
SlideShow->Info displays this section of the help file. 
 
Slideshow->Play  displays all images starting from the first one at a time interval specified in the 
Options screen shown on in Figure 56 on page 50, or selected from the Slideshow->Interval 
menu item. The keyboard  shortcut for this menu item is Ctrl-P. Other slideshow options are as 
shown below: 
 

 
Figure 19 Slideshow Controls 

Clicking the Play menu item or Ctrl-P on the keyboard displays each item sequentially from the 
sequence number defined by Move Play Start To for a period defined by the Interval menu 
option, and the menu item name changes to Pause. The Stop menu item (with keyboard 
shortcut esc) is now enabled, and clicking it returns to caption entry mode. After clicking Stop, 
clicking Play resumes playback from the stopped sequence number. Clicking the menu item now 
named Pause (or clicking Ctrl-P again) stops slideshow playback and the name changes to 
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Resume, with the Play icon   shown beside it. Clicking this (or Ctrl-P) resumes playback. The 

position at which playback is resumed is controlled by the Move Play Start To menu option, 
which is shown in the screen below: 

 
Figure 20 Move To screen 

The Step Forward and Step Back controls move to the next or previous item in the slideshow. 
The left and right arrow controls provide the same functionality is no caption or sub-caption text 
is present. The sequence number of an item is shown at the top left of the screen as shown 
below with sequence number 18: 

 
 
The Pause On Change option n sets parameters to allow the slideshow to automatically pause if 
there is a change between the currently displayed image and its predecessor.  
 
Copy To Folder option (or Ctrl-K) allows copying of the current image (and optionally images 
ahead or behind the current image via the Images Ahead and Images Behind combo boxes)  to a 
folder, the default value of which is My Pictures/Camera Trap Images via the screen below: 

 
Figure 21 Copy to Folder screen 

A different folder can be selected via the Browse button. If an image file with the name shown 
above already exists in the folder, the saved file name has an integer appended to the file name 
before the file extension (eg IMG_0048(1).jpg).  
 
When the current item is a video, it plays from the start and the Play menu item changes to 
Pause. Clicking Pause pauses the video. Video control visibility is controlled by Show Video 
Controls. 
 
Start and End change the current item to the first or last loaded item, and if it is a video, 
playback will start. 
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Video files will play for their duration if this exceeds the slideshow interval, unless the interval is 
less than the time taken to start playing the video, which may be a couple of seconds. In this 
case the next slide will be shown. If the duration of the video is shorter than the slideshow 
interval, the video will be paused at the end until the duration has elapsed.  
 

Skip Uncaptioned omits images and videos which do not have captions from the slideshow 
sequence. 
 
Interval sets the time period of the timer displaying image files via the screen below: 
 

 
Figure 22 Setting slideshow interval 

 
If the time period is shorter than the time taken to load the image (as may happen for large 
images, a short period, or a slow computer), the image is displayed on the next tick of the timer, 
so the actual period between displays will whichever integer multiple of selected period is 
greater than the time taken to load the image. 
 
Repeat Slideshow repeats the slideshow from the start after the last image is displayed if 
checked. 
 
Show Video Controls and the slideshow interval can both be set on the Options screen, accessed 
via File-> Options. 

 
Figure 23 Slideshow Interval and Video Control Showing Setting on Options screen 
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When a slideshow is running, clicking the right or left arrow keys moves to the next or previous 
slide. Clicking and dragging to the right or left has the same effect. The slideshow display via the 
menu Slideshow->Start hides all controls as shown below: 

 
Figure 24 Slideshow display of video via menu, with video controls shown 

Set Modified Date 
Clicking Set Modified button shows the following screen to allow resetting of the Modified date 
and optionally the Date Taken of the current file. The date can be set manually via the Date 
Picker box in the lower LHS of the screen, or selected from any one of the metadata fields 
shown in the box above it. After selection, clicking Set changes the date picker to the selected 
date. Clicking Change Modified then changes the Modified date visible in Windows Explorer to 
the selected value. The Date Taken field (which is always present in JPEG files on Windows) can 
optionally be set to the same value. This may be useful when adding the date as text to an 
image via Auto-Captioning. 
 
 If multiple images have been loaded from a folder or multiple file selection, the files should be 
reloaded to see the effect of the change on the order of display, which by default is ascending 
Modified date. Note that ordering can be also be changed via the Edit->Reorder/Append option 

 
Figure 25 Set Modified Date screen 

Resetting may be useful for presenting a series of images if scanned images are mixed with 
images taken with a digital camera. Modified dates for digital camera images are commonly the 
date at which the photograph was taken, whereas the scanned image Modified date is the date 
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of scanning. The candidate Modified Date is the date and time at which a photo was taken or an 
image scanned. It can be set using the Set button. If the form is closed, a warning message will 
be shown if the Modified date in the Date Picker differs from the file Modified date on loading. 

Adding and Editing Captions 
Captions may be added in one or two parts. The first part (caption) is displayed as centred 
continuous text.  Multiple spaces and newline characters are replaced by a single space. If the 
Multi-Line text option is selected for the sub-caption as shown below, new lines are shown if 
they are present in the data: 

 
 
If the multiple-line sub-caption is exactly the same as the caption, it is deleted and only the 
caption is shown. The amount of space used by the caption part is set between 0 and 25% of the 
original image height from the following options:  

 
Figure 26 Setting Caption Size as a Proportion of Original Image Height 

Setting the proportion to 0% prevents the caption text from being added to image pixels, but 
the caption is still stored in the IPTC Object Name metadata (sometimes called Document Title) 
and in the Windows Title field. This option may be useful when captioning for publications 
where the caption is not required in the image. 
 
The second part (Sub-caption) height can be set between 0% and 200% of the original image 
height as shown below 

 
Figure 27 Setting Sub-caption Size as a  Proportion of Original Image Height 

Setting the Sub-caption size to 0% prevents the sub-caption text from being added to image 
pixels, but the sub caption is still stored in the IPTC Caption/Abstract metadata (sometimes 
called Caption or Description) and the concatenation of Caption and Sub-caption to the XMP 
Description field and in the Windows Subject field. 
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Using Preset Text 
If users wish to select captions or tags from a list rather than typing them in, this can be 
achieved using the pre-set option, which can be accessed via the Presets  button on the main 
screen as shown below: 

 
Figure 28 Preset Screen for Captions and Tags when no Files Loaded 

As there are no pre-defined pre-set text options, only the Add and Close buttons are enabled, 
Clicking Add shows the screen below, which allows definition of one or more pre-set texts. 

 
Figure 29 Screen for Adding Preset Texts 

One or more text strings can be pasted into the white text box. Multiple text options  can be 
pasted using one line per name. After clicking Add and then Cancel, the texts added appear in 
the main Preset screen as shown below: 
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Figure 30 After Adding Pre-set Texts with one or More Files Loaded and one Item Selected 

Checking one or more of the texts (by clicking the text twice) enables the Copy To button and 
the Caption and Sub-caption radio buttons determine whether the selected text is copied to the 
caption (as shown below) or the  sub-caption when Copy To is clicked. 

 
Figure 31 After Copying Selected Text to Caption 

 
If multiple texts are checked, they are separated by commas in the caption and line breaks in 
the sub-caption. 
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One or more checked texts can be deleted via the Delete button (after confirmation) , and if a 
single text is checked, its value can be edited via the Edit button. 
  

Creating Captions and Sub-Captions from Speech 
Caption and sub-caption text can be set from speech by clicking the microphone icon to the left 
of the face icon and caption box: 

 
This shows the speech input screen: 

 
Figure 32 Speech Input Screen 

To create a caption or sub-caption from speech picked up by your computer’s default audio 
capture device, ensure that the peak recording level shown at the top of the screen of speech 
exceeds 50. Then click the Start button. The label will change to ‘Accept Speech, the button will 
be disabled, and a green timer bar will appear and start growing to the right. Then, within 3 
seconds, speak your desired caption or sub-caption (in English only at present) for up to 15 
seconds. After you stop speaking, a transcription of your speech will appear in Transcribed Text 
box and the timer bar will stop moving after a delay depending on the accessibility of the web 
service used for transcription. In the best case this is a few seconds, but if there is Internet 
congestion it may be much longer or the connection may not be made at all, in which case an 
error message appears 
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Figure 33 Speech Input Screen Showing Transcribed Speech 

The text shown in Transcribed Text box can be edited if required and saved to either the Caption 
or Sub-Caption boxes on the main screen (depending on the Save To setting) by clicking Save. 
Clicking Cancel returns to the main screen without copying any text. The Reset button clears the 
Transcribed Text box and allows further speech to be transcribed. Text in the Transcribed Text 
box can be edited before clicking Save. New line characters will be included if the text if saved in 
the Sub-caption but will be converted to spaces if stored in the Caption. 
 
Possible Speech Transcription Problems 
 

1. Transcription accuracy is improved if speech is clearly enunciated. 
2. Speech transcription uses a Web Service and requires Internet access. If your computer 

does not have access to the internet, an error message indicating a connection failure 
will appear in Transcribed Text box. 

3. If speech starts more than 3 seconds after the Start button shows Accept Speech, no 
speech will be detected.   

4.  Problems with audio capture on computers are very common. Some Dell laptop users 
have reported very low microphone levels when using Windows 10. This will result in no 
speech being captured. For example, the computer may not have an enabled default 
audio capture device. In this case, the sound input screen timer will move to 20 seconds 
and a warning message will be shown. To check if this is the case can use the Settings-
>System->Sound option. If an Input Audio device exists and is enabled a screen similar 
to that shown below will be shown: 
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Speaking near the computer should grow the bar shown below Test Your Microphone. 
If the audio input device is disabled, or there is no audio input device available, the 
Input part of the screen will be as below: 

 
You may also need to adjust the Microphone Privacy Settings which are visible by 
scrolling down in the Sounds screen. 
 
You can also access audio devices via Control Panel -> Sound. The Recording tab is 
shown below: 
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The sound level indicator on the right should flash when picking up speech. Clicking on  
a recording device enables the Properties button and the microphone level can be set to 
make speech peak level  register of 50 on the input screen as shown below: 
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Face Recognition 
 
Face recognition in Caption Pro generates a caption based on faces detected in an image. I can 
be performed be either a Standard or a Premium method. The method can be selected via the 
Face Recognition Type screen which is  shown by clicking the face icon beside the caption: 

 
 
Selecting the Premium option enables the Premium parameters. The default Standard method 
performs the recognition locally and has no limitations. The Premium method uses a highly-
rated commercial web service and requires Internet access and an additional payment for more 
than 50 transactions. Purchased licenses may include a number of Premium recognition 
transactions. The Demo and Basic Caption Pro licenses include 50 premium transactions, but up 
to 1000 transactions may be included in the Caption Pro  license or purchased separately as top-
up licenses. The Premium option gives superior performance. 
 
Differences between the Standard and Premium face recognition methods are summarised in 
the following table: 
 

 Standard Premium 

Internet Access Not required Required 

Cost Unlimited use included in all 
licenses 

US$ 0.02 to 0.03 per 
transaction after free 
allowance of 50. 

Privacy All data stored on local 
machine 

Data is stored on various 
Google and Amazon servers 
around the world. Only face 
parameters are stored, not 
images.   

Speed  (dependent on image 
size chosen) 

Slow – highly compute 
intensive. 

Fast – powerful cloud 
computer resources can be 
accessed 

Face Recognition and 
Detection Performance 

Moderate – adjustment of 
similarity threshold often 
required 

Good – algorithm continually 
being improved by web 
service provider.  

Platforms Windows 8.1 and 10 only 64- 
bit 

Windows 7, 8.1 and 10  
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Standard Method 
Selecting the Standard options  brings up the screen as shown below, with detected faces 
framed, and default labels of Person 1,2 etc. applied to each detected face in left-to-right order. 
If no faces have been labelled, a warning message appears. 
 
Faces will be labelled with the reference face label if the detected face is similar to the 
reference face. If the detected face is similar to more than one reference face, the labels are 
separated by backslashes.  

 
Figure 34 Face Recognition screen showing two detected faces with default labels 

Faces can be labelled and used as reference images by clicking inside the frame and entering the 
desired name (or label) for the face in the form which appears as shown below. The default 
name (Person n) appears in the text box. It may be useful to have multiple reference faces for 
the same person, perhaps showing them at different ages or with or without sunglasses. If a 
name has been defined, the Delete Face button is enabled. Clicking it removes the name from 
the screen and the caption box, but does not remove the reference face image file . This can be 
done by editing the Reference folder content via the Ref Folder.. button.  Other reference face 
names can be selected from the dropdown. 
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 When the OK button is clicked, the name is shown in the parent screen as below, and the 
caption is updated: 

 
The caption created from the faces is shown in the box below the image. This string is copied to 
the Caption field of the main screen when the face recognition screen is shown. 
 
Extracted and de-skewed faces with their labels can be seen in the Extracted Faces tab: 

 
Parameters for the recognition process and captioning can be viewed and changed by clicking 
the Show Settings button, whose text than changes to Hide Settings. Clicking it again hides the 
Settings values. 

 
Figure 35 Settings for Face Recognition 

As the face detection and matching is highly compute-intensive, input images are resampled to 
a specified number of pixels before processing to reduce processing times. The number of pixels 
to resample to can be set from the Reduce Size To combo box. The value  depends on the 
number of pixels in the faces to be detected in loaded images. The detection and matching 
algorithm requires that each face should be at least 70 pixels square.  
 
The Match Tolerance value defines the trade-off between precision and recall in the face 
matching process. Low values will give more precise results, but matches may be missed. High 
values tend to match to multiple reference faces. 
 
The Caption radio button group determines whether captions include only recognised faces 
(where the input faces are deemed similar to a reference face) or whether the default labels of 
Person 1,2,3 etc. are included (All).  
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The Ref Folder button allows definition of the folder where reference face images are stored 
(default value C:\Users\<UserName>\Pictures\ReferenceFaces), and editing of the reference 
faces via the screen below: 

 
Figure 36 Reference Face Folder definition 

The Edit button opens Explorer in the Reference folder to show the Reference face images, 
which are JPEG files with the name of the image file being analysed followed by _Facen, where n 
is the position number of the detected face in left-right order. The Delete All button deletes all 
reference faces in the folder. 
 
The labels assigned to the reference faces are shown in the image Title field, which can be 
displayed in File Explorer as shown below: 

 
 
Closing the Face Recognition screen (via the X icon in the top RH Corner), transfers the caption 
to the main screen, where it can be applied (after editing if required) via the Add to Image 
Button. 

Standard Face Recognition Limitations 
The Standard method works best where the faces are oriented toward the camera: oblique 
views may not be detected as faces. The face image should also be contained in a region of at 
least 40 x 40 pixels. Uniform illumination is also required: if one half of a face is much more 
strongly illuminated than the other it will not be detected. The similarity threshold is based on 
comparison of a large number of features and this may result in spurious matches if the 
threshold is set too high. 
 
The analysis and matching process is computationally intensive, so for a small number of 
images, manual captioning of people appearing in an image will be faster and more accurate if 
the faces are known.  

Premium Method 
After selecting the Premium option, the Premium parameters area of the Face Recognition Type 
screen is enabled: 
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Reference faces are stored in the cloud-based gallery with a name automatically generated for 
each user. It can be changed if required. A Top-Up license to increase the number of 
transactions available can be purchased via the Buy button and entered here, or in the main 
License Screen. If the number of transactions exceeds the limit, the Premium button is disabled. 
A transaction is recorded each time a web request is made. This occurs when a reference face is 
defined or deleted, when a name associated with a face is changed, or when faces are detected 
in an image. 
 
After clicking OK, the Premium Recognition screen appears as shown below: 
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 Settings for Premium Face Recognition can be shown by clicking the Show Settings button, and 
are shown above. They are similar to those used for Standard Face Recognition. The input image 
size is shown at the top left, and options are provided to resample it to a specified number of 
pixels which is less than the number present in the original image. A maximum image size of 
1,000,000 pixels or larger will give best results. Resampling to smaller images may result in faces 
not being detected. The guidelines for face and image size in the following section (Premium 
Recommendations for Best Results) should be followed. 
 
A Caption Prefix may be added to any caption derived from the image. The caption with the 
selected prefix is shown on the Caption Pro main screen after face recognition is closed. 
The Match Confidence Threshold  specifies the recognition threshold above which faces are 
recognised and their default names (Person n) replaced. 
 
The Caption box specifies whether labels for all detected faces (including Person n labels) are 
shown, or whether only recognised face labels are shown. The Font Size dropdown specifies the 
size of font used for face labels on the screen below. 
 
The Frame Expansion factor sets the size of the box drawn around the detected faces and the 
boundaries of the region used as a reference face. If the box is too small, faces may be detected 
but may not be able to be enrolled and used as references. The same thing may happen if the 
box is much larger than the face. This setting may be important when the size of faces to be 
identified is a small proportion of the image size, as is the case for group photos with many 
people in them. A warning is given if enrolment fails after specifying a name. The display should 
be refreshed in this case. 
 
The Ref Folder button allows users to specify and view the folder containing the reference face 
images: 

 
 
Image file names in the Reference Folder are composed of 3 parts. The first is the file name of 
the parent file from which the face was extracted. The second part is the name of the gallery 
used by the cloud storage in which face parameters are stored. The third part is the name given 
to the reference face. This name is also added as a file tag. An example of the reference folder 
content is shown below: 
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Files in the reference folder should not be deleted, renamed or moved. Their purpose is to 
indicate the contents of the cloud gallery storage where face parameters are stored. 
 
The Refresh button redisplays the images with settings values as specified.  
 
Reference faces are created by clicking in a detected face to show the Person Name screen, 
from which reference face names can be set, edited or deleted. Characters which cannot be 
used in Windows paths (e.g. /\:?) cannot be used, and names cannot start with the string 
‘Person’. Existing reference names can be selected from the dropdown. If a Reference face is 
selected, the Delete Face button is enabled. 

 
After defining the name and clicking OK, the selected name appears above the face rectangle as 
shown below, and a file is created in the Reference Face folder 

 
 
 
Once reference faces have been defined, loading a new image results in detected faces in the 
image being matched with reference faces. If a match is detected, the detected face is framed in 
orange rather than green, as shown below. If the confidence of the match exceeds the 
threshold value, the name assigned to the reference face is shown. For unrecognised faces, the 
frame is shown in green and the name Person n is assigned, with n increasing from left to right. 
The names shown are listed below the image in a text box, which can be edited: 
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The extracted faces tab shows the content of each of the face rectangles, with the name  and 
confidence value (between 0 and 1.0) where a face has been matched with a reference face and 
the confidence value exceeds the threshold. Where a match is found but the confidence level 
does not exceed the threshold, the name Person n is shown before the confidence level. Where 
no match is found only the name Person n is shown. 

 
When the face recognition screen is closed, the names in the text box below the image are 
transferred to the caption box on the main screen, where they can be added in the usual way. 
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Premium Recommendations for Best Results 
 
Faces need to be aligned approximately vertically to be recognised. Oblique views where some 
face features are not visible will not be detected. 
 
There are two factors which affect the usability of a reference  image: absolute face size in 
pixels and face size relative to the total size of the image. On average, the pixel width between a 
person’s eyes is half the distance of their head width. There is no minimum image dimension 
requirement but there should be at least 64 pixels between a subject's two eyes and for best 
results the head to image width ratio should be no less than 1:8.  
 
Under ideal circumstances images should have at least 160 pixels between the eyes. It is 
generally not necessary to use images with more than 400 pixels between the eyes, as this may 
increase processing time.  
 
 

Adding an Image Sub-Caption 
 
To use a portion of an image as the sub-caption, first select the Image option for the Sub-
caption. This will enable the select button as shown below. 

 
Then load the image file from which to select a region to use as a sub-caption. Either JPEG or 
HEIC format image files can be loaded. Dragging the RHS screen to the right shows more of the 
loaded image. 
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Figure 37 Image Caption Screen  

The loaded image can be shrunk on the screen by a factor determined by the Shrink Image 
Factor combo box on the right of the screen. Using a shrink factor of 4 the display is as below: 

 
Figure 38 Image Caption display with a shrink factor of 4 

The two buttons on the lower left rotate the image 90 degrees counter-clockwise or clockwise if 
required. The screen can be resized if required and the scroll bars used to locate the region to 
be used as a caption. The name of the file is shown below the image. 
 
Once the region has been found, a rectangular box can be drawn around by left-clicking and 
dragging. A rectangle with the colour selected in the Rectangle Colour combo box will then 
enclose the region as shown below: 
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When the mouse button is released only the selected region is shown: 

 
Figure 39 Image Caption Screen After Region Selection 

Note that the rotate buttons are not shown after region selection. Clicking the Restore button 
will show the full image again, from which another selection can be made. 
 
To load a different file to use a sub-caption, click Browse… 
 
Clicking OK makes the selected region available for application as a sub-caption from the main 
screen, which shows the file name of the image caption file in the text box. 
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Figure 40 Main Screen After Definition of Image Caption 

Clicking Add to Image then applies the image caption. The Multi-Line text box is set to “Image 
Caption Added”.  

 
Figure 41 Image  After Addition of Image Caption 

The height of the region into which the image caption is placed (as a percentage of the original 
height) is set by the sub-caption height. If the Sub-caption Height is less than 50% a warning is 
shown.  As the aspect ratio of the image caption is fixed, expanding this height may result in 
truncation of the image caption at the sides. 
 
The aspect ratio of an image cannot be adjusted when applying an image caption. If this is 
desired, a text sub-caption should be added with the aspect ratio set, and then the text sub-
caption should be replaced by an image sub-caption.  
 
When an image caption is added, the image caption is not stored in the file metadata and must 
be redefined if the caption is added again after re-opening. To clear an image caption, click 
Multi-line text, delete any text in the Text box and click Add to Image. 
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Text may be placed above the image by entering in the Caption box as shown below: 

 
Figure 42 Image Sub-Caption and Text Caption Added 

A common requirement for an image caption is for photographs of artworks, where descriptive 
information is supplied in a separate panel as shown below: 

 
Figure 43 Photo of Artwork with Descriptive Panel 

If the artwork is large, the descriptive panel may not be large enough to be readable. By taking 
separate images of the artwork and the descriptive panel, the panel image (cropped and 
resampled) can be used as an image sub-caption as shown below: 

 
Figure 44 Descriptive Panel as Image Caption 
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Note that the Batch button for automatically captioning multiple files is disabled if Image mode 
is chosen for the Sub-Caption mode.  
 
Images with added captions are always saved as JPEG files with extension .jpg. 

 

Applying the Caption and Sub-Caption 
Both the caption and sub-caption can be applied by clicking the Add To Image button or by 
clicking Enter (return) on the keyboard after entering the caption. Non-JPEG format input files 
will be saved in JPEG format. A confirmation screen is then displayed as shown below, indicating 
whether the selected file will be overwritten, or a file created in the folder selected in the 
options screen which may overwrite any previously created file.  

 
Figure 45 Processed File Options Screen 

Processed file options may be changed by clicking the Options button, which shows the screen 
in Figure 66 on page 65. Clicking Do Not Show This Screen again prevents the screen from being 
shown when a caption is applied. If any change is made to the Overwrite status or folder 
location, the confirmation screen is shown again after any caption application. C 
 
If multiple images have been loaded, the caption can be applied by moving on to another image 
with the movement buttons or by using the keypad left and right buttons.  
 
If a file is read-only and the option to overwrite the existing file with the captioned one is 
selected, the file permission will be changed to remove the read-only attribute. 
 
If a previously captioned image is being edited, the existing captions (and multiple-line sub-
caption) are displayed. The heights of each part of the caption bar, the aspect ratio and multi-
line alignment settings are also displayed and can be changed if required. Setting both the 
caption and sub-caption height to zero results in no caption bar being added to the image, but 
caption and sub-caption data is still stored in the file metadata. The “Add to Image” button 
changes to “Add Metadata Only in this case. Tags can be created from caption or sub-caption 
data via the Options screen as described on page  Error! Bookmark not defined.. 
 
The entered caption fills the caption bar space. 
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Figure 46 Different settings for Caption Height for a short caption (left: 15%, centre 7.5%, right 5%) 

The caption is spread over multiple lines if it is too long to fit across the image as a single line. 
The number of lines will vary depending on the size of the caption bar and the length of the 
caption. 

   
Figure 47 Different settings for Caption Height for a longer caption (left: 15%, centre 7.5%, right 5%) 

A multi-line caption of unlimited length may be added entering the required text in the 
multiple-line Sub-Caption box with the Sub-Caption Mode set to Text. Such captions are 
particularly useful for captioning photos of groups of people who need to be individually 
identified, such as school classes or sports teams.  
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Figure 48 An Image with a Continuous Caption and Multi-line Sub-Caption 

The maximum percentage of the original image height used for the multi-line sub-caption can 
be specified using the combo box at the right of the text box (20% in the above example). The 
actual percentage used depends on the length of the longest of the multiple lines. The font size 
is adjusted to make the longest line fit across the image width. The caption can be left-aligned 
below the image (default option) or centered using the Alignment radio buttons. The title and 
caption can be applied by clicking the Apply button. 
 
 The Caption and Multi-line sub-caption can be cleared by clicking the Clear button or by 
emptying either text box and clicking Apply. Caption data is stored in the EXIF metadata field 
XPTitle and sub-caption data in XPSubject. Any data written in these fields is shown when the 
file is loaded, allowing already captioned images to have their captions changed. Caption data is 
also written to IPTC Object Name (or Title) field and multi-line sub-caption to the IPTC 
Caption/Abstract  (Caption or Description) field. Any newline characters in the multiline 
character set are replaced by spaces. A concatenation of the Caption and Sub-Caption data(with 
new line characters replaced by spaces)  is also written to the  XMP Description field. If both 
fields are empty, no IPTC or XMP data is changed. 
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Captioning Video Files 
Video files in .mov, .mp4 and .3gp format can have both caption and sub-caption data added to 
their metadata by clicking Add to Image and selecting Metadata Only from the screen below 
offering to embed the caption in the video. 
 

 
Figure 49 Video caption options 

 Closing the form adds metadata only.  Caption data is stored in the video file Title metadata 
field (often shown as Movie Name) and the sub-caption in the Album field. Clicking Embed re-
encodes the video, writing the caption in a bar below the video for .mp4 and .mov files. Sub-
captions are not shown. The original height is stored in the Comment field.  The Metadata Only 
option executes much more quickly than the Embed option, but the caption and sub-caption 
can only be viewed using Caption Pro. (VLC Media Player briefly shows the caption when the 
video is played as shown in Figure 51.) 
 
Videos in unsupported formats can be converted to .mp4 by many video editors, including 
ClipChamp, or by the command line program ffmpeg. 

 
Metadata can be viewed in a bar below the video after application as shown below: 

 
Figure 50 Video file after adding caption and sub-caption data to metadata 

If the video is loaded into VLC Media Player, the Title metadata is shown as an overlay as below, 
but fades out after a few seconds. 

https://clipchamp.com/en/
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Figure 51 VLC Media Player displaying caption metadata 

 
If the Embed button is clicked, caption data is embedded in the video (for .mov and .mp4  files 
only) using the ffmpeg application to re-encode the video with the caption added. Caption data 
is displayed as a single line, sized to fit into the available width as either black text on a white 
background (default) or vice versa. This format can be changed via the Fonts and Colours tab of 
the Options screen. An example of an embedded caption is shown in  Figure 53. 
 
The embedding process is highly CPU-intensive and it is recommended that the PC is set to run 
at maximum performance (via the slider shown when clicking the battery icon) in order to 
achieve the estimated embedding time, which usually greater than the video duration. A splash 
screen shows the progress of the embedding, and supports cancellation as shown below: 

 
Figure 52 Embedding progress screen 

On completion of the embedding, the captioned video file is shown as below.  
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Figure 53 Video file with embedded white-on-black caption 

The caption can be edited in the same way as for image files. Embedded or metadata-only data 
can be cleared using the Clear button. 
 

Editing File Metadata After Captioning 
Three EXIF metadata fields (XP Title, XP Subject, and XP Comment) are used by Caption Pro to 
store caption and sub-caption data (XP Title and XP Subject respectively) and image 
configuration data (XP Comment). The Title and Subject metadata shown in the Details tab of 
File Properties for a captioned file may show this data when examined in File Explorer. Because 
this data is stored in double-byte form to accommodate non-English captions, it will render as 
Chinese characters. If editing captions which have been applied with a version of Caption Pro 
3.1.95 or earlier, captions and sub-captions are only stored in single-byte format and will render 
as Chinese characters in later versions (which use double-byte storage) in the caption or sub-
caption box. If any double-byte characters (typically non-English) are found, the screen below is 
shown: 

 
Figure 54 Non-English character decoding screen 

If the caption or sub-caption was created as English text in single-byte format, the English 
characters option should be selected. If the caption is intended to use non-English characters, 
the Non-English option should be selected. The screen will be shown each time a file is 
displayed unless Don’t Show this screen again is checked. Note that these settings are not 
persisted once Caption Pro is closed.  
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Warning: Don’t Edit Title, Subject or Comment Fields after Captioning 
Don’t try and edit any data in these fields via the Explorer File Properties Details tab after 
captions and sub-captions have been applied, as this will affect the editability of embedded 
captions, as changing these fields will change the XP Title, XP Subject or XP Comment fields. 
Adding or changing the Caption field via Photo Gallery will overwrite XP Title field. 

Auto-Captioning 
The following screen is shown when clicking the Auto-caption button when an image is shown; 

 
Figure 55 Auto-caption screen 

Clicking the Apply button in the Metadata Caption Sources box applies captions and sub 
captions taken from the sources shown to the current file. These can be the file name, the 
folder name or the file location as derived from file GPS data.  If the options need to be 
changed, clicking the Change.. button shows the Options screen, from which sources for Auto-
captioning can be selected from the controls in the red rectangle: 

 
Figure 56 Options screen 
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The default source for the Caption is the folder name, and the default source for the Sub-
caption is the file name. Other source options are IPTC Title (or Object Name field) , XMP Title 
Google Photos Album, Windows 10 Photos People, Windows Title and Faces for the caption, and 
IPTC Description (or Caption/Abstract field) , XMP Description, Google Photos Description, 
Photo Gallery, Picasa or Windows Date Taken for the sub-caption. Captions added to iPhone 
images in the iPhone app Photos appear in Windows Title field (and also Windows Subject and 
EXIF Image Description), 
 
IPTC and XMP fields are often set in images taken by professional photographers who wish to 
record a great deal of information (including copyright) about each image. Programs such as 
Adobe LightRoom or IrfanView can be used for this purpose. 
 
The Faces option detects faces in present images and creates a caption from labels applied to 
the faces in left-right order. In order to use this option, at least one labelled face must be 
created.  The Standard or Premium method is used according to the option set when creating 
reference images. 
 
The Photo Gallery option reads the metadata added by Windows Photo Gallery (a consumer-
level photo viewing, editing and metadata addition program)  and adds it as a sub-caption, with 
one line used for each of the four fields definable in Photo Gallery (Caption, People, Tags, and 
Geotag). If the selected field is not present, no caption is added to the respective caption or sub-
caption. Picasa reads all the tag information applied to images in Picasa. 
 
Another sub-caption option is Location, which is taken from GPS data which may be present in 
photos taken on a mobile phone if the phone has reception at the location where the photo was 
taken. This data (in the form of latitude and longitude in decimal degrees) is converted to an 
address via the Google Maps Web Service. Internet connectivity is required for this to work. If 
the service is not available, the default sources for Caption and Sub-Caption will be set. 
 
 Options chosen on this screen will be applied to multiple files via the Slideshow button (see 
page 20). The None option does not set caption data from any source. Any pre-existing data will 
be retained in this case, unless the Persist and Apply Captions checkbox is checked. 
 
Selecting the Create Caption button in the Caption from Image Analysis box in the Auto-Caption 
screen sends the image to a Microsoft Image Analysis web service and retrieves an automated 
description of the content, which is written into the Caption box, but not applied automatically. 
The results are somewhat generic: individuals may be recognized as celebrities or public figures 
with a similar appearance: 
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Figure 57 Example of Create Caption results (left) and a photo of one of the incorrectly identified subjects 

Leon Panetta is an American politician, who does not appear in the above image, even though 
the backdrop is correctly identified as a house. 
 
An internet connection is required to use Create Caption. An error message will appear if there 
is no connection. 

Captioning Data from Google Photos 
Images stored in Google Photos cannot be captioned directly, but if a Google Photos Album is 
downloaded,  a local Zip file is created in the Downloads folder, which can be unpacked to 
create a folder with the images as uploaded to Google Photos. These can then be captioned 
using any of the facilities of Caption Pro and then uploaded as a new album. Uploading a large 
number of files as a new album may be very slow. 
 
If the entire album content is to be auto-captioned (for example, to add Date Taken and 
location), there is an option to exclude video files from captioning, as processing of these can be 
very slow. It is recommended to stored the captioned files in a different folder, as output files 
from Caption Pro are always in JPEG format, and Google Photos images are not necessarily in 
this format and will not be overwritten. 
 

Using Caption Data from Google Photos Description 
Google Photos descriptions can be used a source of caption data, but the process is somewhat 
cumbersome. It only operates on files from a Google takeout archive. If the option is selected 
but files are not from a takeout archive, then no data from Google will be used for captioning. 
Comments from other Google users in shared albums (shown as Activities) are not accessible 
 
Google Photos can organise photos by date and location, for which the data is stored in image 
file, and also perform automated image analysis, notably facial recognition, which allows images 
containing a labelled face to be identified across the image store. These groupings are can be 
grouped into albums, and  images can also be manually grouped in the same way. Captions (or 
descriptions) can also be added to individual images, but these are only visible in full via the Info 
tab as shown below: 
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Descriptions are shown to the right of the image in normal view, but with no line breaks: 
 

 
Descriptions are not shown at all in slideshow view, as the image occupies the entire screen 
 
All of this additional data generated by Google or added by the user is not available if the image 
is downloaded via the Download menu item. However, it can be obtained by downloading all of 
the Google Photos data via the Takeout options. To download your photos, type 
https://takeout.google.com/. If you are not logged in to Google you will be prompted for your 
credentials. After supplying them you will see the following screen, from which the option to 
only select Google Photos should be selected: 

https://takeout.google.com/
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Caption Pro User Manual 

 55 Aleka Consulting 
  www.alekaconsulting.com.au 

After clicking More Info, the option download all albums or only selected ones (as shown below) 
appears: 

 
 
The next step is shown below. It allows exports to be made periodically in various formats and 
to various destinations. 

 
 
After clicking Create Export, a progress box appears: 
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The notification email (sent to your Google email address) is as shown below: 

 
After clicking on Download your files and re-authenticating, the screen below is shown, and 
clicking Download creates a Zip file in the Downloads location. 

 
The downloaded Zip file has the name takeout-XXX.zip, where XXX is a unique string containing 
the current UTC date. Unpacking it generates a folder tree where each album is a separate sub-
folder. If all albums are selected the takeout file contains albums for each year which photos 
were taken by default. If an album is created by clicking on one of the People icons to show all 
photos containing the selected face and then Share as album, an album will be created 
containing all the photos with the selected face, which can be included in the takeout archive. 

 
 
After the takeout archive file is unpacked, processing with the Google Photos Album option for 
the Caption uses the name of Google Photos album included in the takeout folder structure. The 
Google Photos Description option for the sub-caption uses the value entered for the image 
Description, which is visible in the Info pane, and stored in the .json file for each image in the 
unpacked takeout archive.  
 
After captioning, the files can be uploaded as a new album from Google Photos if desired. 
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Using Caption Data from Windows 10 Photos People 
 
Windows 10 contains a photo viewing and editing application called Photos, which has many of 
the features of Google Photos, including automatic detection of faces and other named features 
(e.g. animals, food etc.) in images. Faces can be  labelled as shown below, where the first three 
faces are labelled S, J and R. The number of photos containing the person are shown beneath 
the face. 

 
Clicking on the face shows all the images containing that face: 
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The data about which named faces appear in images can be extracted and added to the caption 
using the Windows 10 Photos People option. Extracting this data requires location of the Photos 
database.  
A screen for this purpose is shown when the option is selected: 

 
If the database file does not exist at the default location, it can be located via the Browse 
button. Once it has been located, any image selected for display which contains people named 
in Photos has the names of people added to the Caption box as shown below: 

 
Figure 58 Image captioned by names of people identified with Windows Photos 

This feature allows people in a single photo to be visibly named, rather than having all the 
photos containing a person to be grouped together. 
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Adding a Logo to a Caption 
 
A logo can be added to the caption bar by selecting a logo file from the Options screen and 
checking the Use checkbox: 

 
The logo file is selected from the browse button and can be in JPEG, TIFF, BMP, GIF or PNG 
format. The logo image is shown below the location textbox. 
 
The logo is added at the bottom left of the caption bar and its size is scaled so that its height is 
90% of the height of the caption bar as shown below. The caption is placed to the right of the 
logo: 
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Aspect Ratio 
The aspect ratio of an image is the ratio of its width to its height. It is significant when images 
are printed on media of fixed dimensions, as an image whose aspect ratio differs from that of 
the print will either be truncated or stretched to display the image on the print. Truncation is 
much more common, as its effects are less noticeable unless a caption has been added below 
the image, in which case it may not be visible. If an image is displayed on an electronic device, 
the image can be scaled to be shown in its entirety whatever its aspect ratio, but some 
electronic image repositories may use square images as a visual index or an indication of graphic 
content. If a caption has been added below the image, this may not be shown if the aspect ratio 
is much less than 1.0 (portrait mode), as a square image may be generated by truncating the top 
and bottom of the image 
 
To deal with this situation Caption Pro allows white padding to be added to a captioned image 
to make the processed image have a range of aspect ratios. Aspect ratio can be set in the main 
screen, with options as shown below: 

 
Selecting Not Set does not add any padding to an image and removes it if it is present. The Auto-
orient options add a caption bar below the oriented image, so that the orientation of the 
captioned image is the same as the image before processing and the ratio of longest to shortest 
side is as set. One of these options is most suitable for preparing photos for printing.  
The Landscape and Square options orient the captioned image in Landscape mode. If the input 
image is in Portrait mode, a large amount of padding will be added at the side. Selecting any of 
the Portrait options will result in the output image being in Portrait mode. Landscape images 
will have a large amount of padding at top and bottom. 
 
Selecting the desired aspect ratio does not change the image: Add to Image should be clicked 
after making the selection. 
 
The default value of Not Set does not add any padding of the captioned image and the aspect 
ratio is determined solely by the input image aspect ratio and the size of the added caption. 
Results of captioning with different aspect ratio values are shown below. A border has been 
added to all images to highlight the effect of changing aspect ratios. 
 
Note that aspect ratio cannot be set if only an image sub-caption is applied but if a text sub-
caption is set and the aspect ratio adjusted, the text sub-caption can be replaced by an image to 
achieve this effect. 
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Figure 59 Effect of changing the aspect ratio on processed image: Not Set (Top Left), 1.0 (Top Right), 0.66 (Bottom 
left) 1.6 (Bottom Right) 

Translator 
A Translator button is provided to allow easy access to automated translation via the Google 
Translate website. Translated captions can be copied from this and pasted into the Caption text 
box.  
 

   
Figure 60 Caption translated into Chinese(left), Spanish (centre), and Vietnamese (right) 

Having the caption included in the image allows display of a slideshow in other applications 
(such as Google Photos) including captions. As the caption string is also stored as file metadata, 
the last-entered caption is shown below the image as well as within the image. This can be 
edited (or removed by deleting all the caption characters) before re-applying the caption. 
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The Modified date of the file is not changed by the action of adding the caption, but it may be 
useful to have this date set to the date on which the image was recorded via the Options 
setting. 
 
Because the caption is shown in a caption bar of known dimensions below the image, it is 
possible to remove captions or re-apply a different caption to an image without having to keep 
track of multiple copies created by other applications for adding text to images. 

Editing Images 
Images (but not videos) may be edited by clicking the Edit button to the right of the movement 
controls, using the Microsoft Paint application 

 
Figure 61 Example of image editing (cropping) using Paint 

After the editing has been completed, the file should be saved and Paint closed using the x icon 
at the top right. The edited image will then be displayed in Caption Pro. Note that the Modified 
date will reflect the date of editing. 
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Viewing File Metadata 
Metadata for the currently viewed file can be shown by clicking the Metadata top-level menu 
item. Metadata from the Windows filesystem is shown first, then image-specific metadata. 
There may be hundreds of fields present. ICC Profile entries for red, green and blue are not 
shown as they are very long. 

 
Figure 62 Example of part of file metadata 

Copying  Files and Editing File Selections 

Copying 
Caption Pro can be used for selection and copying of items on the basis of whether or not they 
have been captioned. The menu item Edit->Copy/Move Captioned allows the user to specify a 
folder into which captioned files are copied or moved. Files can either overwrite existing files in 
the selected folder with the same name or if they have the same name as an existing file, they 
can be stored with a new file name with a bracketed number appended to the file name just 
before the file extension. A sequence number can be optionally inserted before the file name, 
allowing items to displayed in an arbitrary order. 

  
 
Figure 63 Example of Copied Captioned Files with Sequence Numbers 
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This capability allows selection and captioning to be done at the same time. 
 
Files can also be copied in the same way irrespective of whether they have been captioned or 
not via the Edit-> Copy.. menu item. This allows creation of an arbitrary ordering which can be 
accessed by sorting the files by file name if a sequence number is inserted. 

Editing File Selections 
Files can be re-ordered via the Edit->Reorder/Append menu item. This shows Drop/Paste 
screen, only with the loaded files obtained from those currently displayed. This selection can be 
added to via the Drag/Drop and Paste functionality, and re-ordered by checking Edit Order and 
graphically moving images as shown below. Files can be deleted from the selection by selecting 
them and clicking Delete Selected 

 
Figure 64 Drop/Paste screen showing thumbnails from loaded selection 

Search 
 Caption Pro can search within the loaded images for words or phrases appearing in the caption 
or sub-caption. This functionality is accessed via the File-> Search menu item, which shows the 
following screen: 

 
Figure 65 Search Screen 

Entering a search string and clicking Search or Enter in the Search Phrase box searches applied 
captions for the phrase. Clicking Load Results replaces the currently loaded files with those 
whose captions meet the search criterion. The progress of the search is shown in the Status 
label, and the search can be stopped by clicking the Stop button. 

Options Screen 
 
This screen has two tabs – Captions and Fonts and Colours 



Caption Pro User Manual 

 65 Aleka Consulting 
  www.alekaconsulting.com.au 

Captions 
The Captions tab is used for general settings for Caption Pro operation, and Fonts and Colours is 
used to define Font properties for the caption 

  
Figure 66 Options Screen – Captions Tab 

Caption and Sub-Caption Sources 
Setting the Caption Source options to anything other than None allows captions and sub-
captions to be automatically created from any of the specified sources. Any existing metadata in 
XPTitle, XPSubject or XPComments is overwritten or cleared if None is selected. If Faces is 
selected, the names of people detected by face recognition are added as a comma-separated 
list. If Recognised is selected, only recognised faces names are added. If All is selected, 
unrecognised faces are added to the list as Person1, Person2 etc. 
 
If no metadata is found for the any retrieved metadata selections, a blank value is set. No value 
is set if the file contains no location data.  
 
A range of sources can be used for the sub-caption as indicated in Figure 66. Using Date Photo 
Taken as a source takes the first EXIF metadata field whose name starts with ‘Date/Time’ 
(usually Date/Time Original). If this date is not present, the file Modified date is used. This date 
can be set for individual files via the Set Modified button. Location data is presented as a text 
string derived using reverse geocoding (via the Google Maps web service) using GPS data stored 
as EXIF fields. An internet connection is required to access this service. GPS data is commonly 
present in images from mobile phones but not in digital camera images. The data as presented 
is not always accurate and accessing the web service may slow processing of multiple files. 
Failure of web service is recorded in the error log for multiple file processing. 
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Examples of results from different source combinations of these are shown below: 

   
Figure 67 Captioned image using different metadata sources 

The left image sets the caption from the folder and the sub-caption from the file. The centre 
image sets the caption from the file, and the right-hand image sets the caption from the folder 
name and the sub-caption from the location. The caption is set to 10% of image height and the 
sub-caption to 5%. 

Using Metadata Created by Other Applications 
Metadata created by  Windows Photo Gallery, Google Picasa and Google Photos  can be used to 
automatically set Caption and Sub-caption values. For Photo Gallery and Picasa, the metadata 
displayed is already contained in image file metadata. In the case of Google Photos, data has to 
be downloaded as part of Google takeout, through which all data stored by Google applications 
can be downloaded. After unpacking the downloaded Zip file, folders will be created for all 
manually created albums and for all days corresponding to the dates on which the photos were 
taken. Inside each folder are the image files and JSON format files containing the metadata for 
each file, including any caption or description values entered. Within Google Photos, the 
description is visible in the info tab and at the bottom left of the image for a limited period as 
shown below. Multiple line captions are concatenated. No captions are shown in slideshow 
mode. Comments from other users can be shown by clicking the rectangular icon at the bottom 
right of the image. Comments and description cannot be shown together. 

 
 

 
Figure 68 Google Photos Description in Info pane (top) and beside image (bottom) 
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After embedding the caption data in the image, the album name and caption data is readily 
visible in the image as Caption and Sub-caption respectively  as shown below: 

 
Figure 69 Image after creating Caption and Sub-Caption from Google Photos data 

After the album name and caption data have been embedded in images as shown above, they 
can be uploaded as a new Google Photos album, with text always visible, even in slideshow 
mode. 

File Metadata 
The File Metadata radio buttons control whether only the EXIF data is copied to the captioned 
file (Exif Only), whether all metadata (including EXIF, IPTC and XMP) is copied or whether EXIF 
and key IPTC fields are copied. The default value is EXIF and Key IPTC fields. Key IPTC fields are 
Object Name (often shown as Title), Caption/Abstract, Keywords, Date Created, Time Created, 
By-Line and Copyright. If only EXIF data is copied, Write Windows Metadata is automatically 
checked and the Caption field is written to the Windows Title field and the Sub-caption to the 
Subject field.  File Explorer search can then be used to identify files containing a particular string 
using the syntax Title:searchstring or Subject:searchstring as required. The result of this setting 
is displayed in the Processed File Options screen shown in Figure 45 on page 44.  
 
Note that fastest processing is achieved using the EXIF Only option. 
 
The Write XMP/IPTC Metadata checkbox determines whether caption and sub-caption text is 
written to IPTC and XMP metadata fields. If it is checked, caption text is written to the IPTC 
Object Name field (often shown as Title), sub-caption text to the Caption/Abstract field and a 
concatenation of the Caption and Sub-caption fields is written to the XMP Description field. If it 
is not checked, existing values of XMP and IPTC fields are not changed. 

Persist Captions 
The “Persist Captions” checkbox allows the content of caption and multi-line sub-caption boxes 
to be retained when moving to another file when multiple files are loaded. 
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Overwrite Original 
If checked, the Overwrite Original File checkbox replaces an opened JPEG file by the one to 
which a caption has been added. If it is not checked, the captioned file is saved as a new file 
with a sequence number in brackets added at the end of the file name if the destination file is 
present. If this file is edited, a second sequence number is added. If non-JPEG files are opened, 
the captioned file will be saved with a .jpg extension. 

Folder Location 
The Folder Location box allows captioned files to be stored in a folder other than the original 
folder in which the file was located. If  Other Folders is selected, all captioned files are stored in 
there. A sequence number is added if the same file name appears in more than one folder.  

Save Quality 
The Save Quality combo box is used to specify the compression quality of the processed image  
files. The default value of 75% gives acceptable results for screen viewing. The 94% value gives 
better quality but a larger output file size. 

Resize Captioned Images 
The Resize Captioned image checkbox allows captioned images to resampled to a size specified 
by the drop-down (100%, 75%, 50% and 25%).  

Don’t Show Processed File Options 
The “Don’t Show Processed File Options” checkbox is ticked if the option has been selected on 
the Processed File Option screen shown in Figure 45 on page 44. 

Slide Show Interval 
The Slide Show Interval shows the time for which each image is shown in a slideshow, in 
milliseconds. If the image takes longer than the specified interval to load, it will  be shown after 
the next time interval. 

Repeat Slideshow 
If checked, the slideshow repeats from the start once the last image has been displayed. If 
unchecked, the slideshow stops after the last image 

Show Video Controls 
The Show Video Controls checkbox shows the video controls if checked and hides them if 
unchecked. 

Logo 
A logo image can be added to the sub-caption by selecting an image file as described on page 
59. The Use Logo checkbox should be used to apply the caption 

File Order in Folders 
The File Order in Folders combo box allows selection of the order in which multiple files in 
folders are displayed. Options are by ascending Modified date, file name, Created date and date 
taken. The Date Taken option is much slower to display large data sets. If no Date Taken data is 
present, the Modified date is used instead. 

Restore Defaults 
This button restores all Options to their default values. 
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Fonts and Colours 

 
Figure 70 Fonts and Colours Screen 

This tab of the Options Screen allows setting of font colours and styles. All installed fonts are 
displayed in the Font lest box. The default font/colour combination is Arial in black on a white 
background.  The appearance of the text in the caption and sub-caption boxes on the main 
screen can be previewed after selection. Note that some fonts do not distinguish very much 
between upper and lower case. 
 
Font colour and style and background colour are stored in image metadata and different 
combinations may be used for different images, but the details specified in this screen on the 
last occasion it was changed are saved by Caption Pro and used as the default. 
 
The embedded video caption style can be set to either black text on a white background or 
white text on a black background. The font style (Cascadia Code) cannot be changed. 

Printing 
Caption Pro supports printing of any displayed image (but not videos) via the File->Print.. 
option: 
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Figure 71 Selecting Print Option 

Clicking this shows the Print Dialog screen, which allows selection of any accessible printer or 
output option: 

 
Figure 72 Print Dialog Screen 
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The Printer properties allow a preview of printed output via the Print Preview checkbox at the 
lower left: 

 
Checking this option and clicking OK and then OK on the Print Dialog Screen shows a preview 
similar to that shown below: 
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Figure 73 Print Preview Screen 

The image is centred in the paper size and can be printed by selecting Print from the Preview 
screen. 
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Help & Support 
The help options shown below are available: 

 
Figure 74 Help Options 

The Hints option shows the Hints screen giving a summary of general processing aims as shown 
below: 

 
Figure 75 Hints screen 

Help data sub-menu items give information on loading from one or more files, files in a folder, 
or via paste or drag and drop. Appending and re-ordering of files is covered by the last option. 
 
Face Recognition gives information on face recognition process. 
Caption Pro Manual opens a PDF version of this manual 
 
Help shows this document as a Compiled Help version of this manual with easy access to 
sections. 
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Support is used for capturing data used for support purposes as shown below. The Support Data 
Zip file (SetTags Support.zip) is created in the selected folder 

 
Figure 76 Support screen. 

Videos provides links to various “How To” videos on YouTube. 
 
Check For Update compares the version number of the current application with the latest 
release and offers to download it from the Aleka Consulting web site, and then install it. 
 
About provides information about the application: 
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Errors 
Errors generated by any Caption Pro operation can be viewed by clicking the top-level  Errors 
menu item as shown below: 

 
Figure 77 Errors from Current Instance 

The default option is to show only errors which have occurred during the current Caption Pro 
run, (Current Instance in the combo box to the right of the error display but All errors can also 
be displayed: 

 
Figure 78 Display of All Errors 
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Appendices 

1. Adding Captions to Images Shown in Google Photos 
 
Google Photos provides automatic cloud storage, backup and sharing for images recorded on 
mobile devices. It can also provide these services for images stored on a PC or Mac as Desktop 
application. As well as automatic image analysis and sorting, it allows the creation of user 
Albums, which are ordered collections of selected images which can be displayed as a slideshow 
or shared with remote users. The Google Photos mobile application does not support download 
of all the images in an album, but the Desktop version does. On mobile phones, individual 
photos can be downloaded to the Camera Roll if it is not already there, but the cropping of 
images to a square format when zooming the screen view out may mean that the caption bar is 
not visible until the screen view is zoomed in or the full image is viewed if the image is portrait 
rather than landscape mode. Images from an album can be downloaded as a Zip file, which has 
the name of the album, and contains all the album images (and videos if included). Caption Pro 
can be used to add captions to album images, which can then be uploaded back to Google 
photos to provide an individually captioned album. Captions already added in Google Photos 
can also be used to automatically populate the Caption and Sub-caption fields as described on 
page 66, if all Google Photos images are downloaded as a takeout. 
 
The option to set the Modified date to the date of recording should be checked to ensure that 
the recorded date is available when the captioned album images are uploaded to Google 
Photos. 

 
Google Photos may be accessed from Caption Pro via the File->Google Photos menu item. You 
will need to supply your Google credentials in order to access your photos. 
 
 The main Google Photos screen is as shown below: 

 
 
Photos can then be selected and the download option selected: 
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Selecting Download creates a Zip file of the selected photos called Photos.zip. This archive 
should then be extracted into a folder. The folder can then be opened using Caption Pro and 
captions added: 

 
These images can then be uploaded to Google Photos via the Upload button: 
 

 
After the user has selected the items to upload, Google Photos offers to place the images in an 
Album. This option may be selected if desired. 

 
 
After upload, the captioned images appear beside the originals, which can be deleted if desired. 
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If the Google Photos images have already been added to an album, this can be downloaded as a 
Zip file and the images processed and uploaded again in the same fashion. Images will be 
ordered by file Modified date in an album. 
 


